1C шаблоны и готовые решения

Ноябрь 12, 2014

Программно открыть внешний отчет или обработку

Filed under: — admin @ 9:51 дп
Функция ОткрытьВнешнийОтчет(ИмяОтчета) Экспорт
 
	ПутьКВременномуФайлу=КаталогВременныхФайлов()+
"ВременныйФайл" + формат(ТекущаяДата(),"ДФ=ddMMyyyyhhmmss")+ ".tmp";
	о = Справочники.ВнешниеОбработки.НайтиПоНаименованию(ИмяОтчета);
	
	Если о=Справочники.ВнешниеОбработки.ПустаяСсылка() Тогда
		Возврат неопределено;	
	КонецЕсли;
	
    Справочники.ВнешниеОбработки.НайтиПоНаименованию(ИмяОтчета).ХранилищеВнешнейОбработки.Получить().Записать(ПутьКВременномуФайлу);
	
	Если о.ВидОбработки = Перечисления.ВидыДополнительныхВнешнихОбработок.Отчет Тогда
    	ВнешниеОтчеты.ПолучитьФорму(ПутьКВременномуФайлу).Открыть();
	КонецЕсли;
	
	Если о.ВидОбработки = Перечисления.ВидыДополнительныхВнешнихОбработок.Обработка Тогда
		ВнешниеОбработки.ПолучитьФорму(ПутьКВременномуФайлу).Открыть();
	КонецЕсли;
	
    УдалитьФайлы(ПутьКВременномуФайлу);
	
	Возврат неопределено;	
	
конецфункции

Powered by WordPress

Яндекс.Метрика nikol_dn@list.ru