1C шаблоны и готовые решения

Февраль 27, 2018

Шаблон для работы с web сервисом.

Filed under: — admin @ 5:37 дп

Шаблон для работы с web сервисом без создания WS-ссылки в конфигурации.

//Создаем клиентский прокси объект для вызова веб-сервиса.
Функция ПолучитьWSПрокси(Объект)
	
	Определение = Новый WSОпределения(Объект.МестоположениеWSDL, Объект.ИмяПользователя, Объект.Пароль);	
	Прокси = Новый WSПрокси(Определение,Объект.URIПространстваИменСервиса, Объект.ИмяСервиса, Объект.ИмяПорта);
	Прокси.Пользователь = Объект.ИмяПользователя;	
	Прокси.Пароль = Объект.Пароль;
	Возврат Прокси;
	
КонецФункции

//Инициализируем структуру с параметрами Web сервиса
Функция ПолучитьПараметрыWebСервиса()
	ПараметрыСервиса = Новый Структура();
	ПараметрыСервиса.Вставить("ИмяПользователя","User");
	ПараметрыСервиса.Вставить("Пароль","123456");
	ПараметрыСервиса.Вставить("МестоположениеWSDL","http://webservices.ru/customwebservice/ws/GetCustomerData?wsdl");
	ПараметрыСервиса.Вставить("URIПространстваИменСервиса","CustomerData");
	ПараметрыСервиса.Вставить("ИмяСервиса","GetCustomerData");	
	ПараметрыСервиса.Вставить("ИмяПорта","GetCustomerDataSoap");	
	Возврат ПараметрыСервиса;
КонецФункции

//Вызываем Web метод сервиса
&НаСервере
Процедура ТестВебСервисаНаСервере()
	ПараметрыWebСервиса = ПолучитьПараметрыWebСервиса();
	Прокси = ПолучитьWSПрокси(ПараметрыWebСервиса);
	Ответ = Прокси.GetCustomers();
КонецПроцедуры

//Клиентский вызов
&НаКлиенте
Процедура ТестВебСервиса(Команда)
	ТестВебСервисаНаСервере();
КонецПроцедуры

Powered by WordPress

Яндекс.Метрика nikol_dn@list.ru